docker部署elasticsearch8

docker部署elasticsearch8

月光魔力鸭

2024-08-22 15:25 阅读 478 喜欢 0

docker compose

部署方式为:docker compose elasticsearch版本:最新版 8.15

elastic docker地址

docker.elastic.co/elasticsearch/elasticsearch:8.15.0

创建文件夹

mkdir -p es/data es/log es/plugins
chmod -R 777 es

docker-compose.yml

version: "3.8"
services:
  elastic:
    image: docker.elastic.co/elasticsearch/elasticsearch:8.15.0
    container_name: es
    privileged: true
    ports:
      - 16746:9200
    mem_limit: 1g
    volumes:
      - ./elasticsearch.yml:/usr/share/elasticsearch/config/elasticsearch.yml
      - ./es/data:/usr/share/elasticsearch/data
      - ./es/plugins:/usr/share/elasticsearch/plugins
    environment:
      - discovery.type=single-node
      - TZ=Asia/Shanghai
    networks:
      - es-net
networks:
  es-net:
    external: true

这里部署的是单节点

docker 创建 network

docker network ls
docker netword create es-net 

elasticsearch.yml

# 配置host为0.0.0.0 允许远程访问
http.host: 0.0.0.0
# 跨域配置
http.cors.enabled: true
http.cors.allow-origin: "*"
# 关闭密码访问
xpack.security.enabled: false

增加ik插件

github地址: undefined 由于ik更新慢,版本不对应,加到 es-root/plugins/ik 后会启动失败,修改 plugin-descriptor.properties文件中的elasticsearch版本即可。

转载请注明出处: https://chrunlee.cn/article/elasticsearch-in-docker.html


感谢支持!

赞赏支持
提交评论
评论信息 (请文明评论)
暂无评论,快来快来写想法...
推荐
当我们安装nginx发现少了一些需要的模块的话,需要重新安装,那么如何来操作呢?
mysql 报错: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock
昨天搬家,又重新折腾了下小主机,准备安装一个服务器管理工具,查了下比较不错的有cockpit,webmin,首先由于cockpit 官网界面不错,优先用了这个,不过安装后启动报错,这块也不太懂,也没查到,就先换了试试webmin.
记录一次增加定时任务的过程,这里简单记录下防止遗忘。
centos 下 sysstat 安装及使用
家里多了一块硬盘,准备加到小主机上,这里简单记录。
最近的几个服务器由于设置问题,总是被登录并种上病毒,主要还是通过ftp进来的。
前几天安装的centos8 最近还是没能逃过卸载的命运,现在安装了 centos8 stream 了,真爽,之前的网卡怎么都读取不出来,换这个秒出,连无线都能直接连了,索性直接安装了GUI版本